Progress Appserver Question

DCraig

New Member
Hi All,

I have a .wsm file i am using to add a new web service to the progress appserver which has deployed fine. However, when i consume the web service from .net code the logical/boolean output parameter from the .p file that runs when i call the appserver web service procedure is of type 'bool?' however i would like it to come through as 'bool'. My .wsm file has the following parameter definition:

<Parameter allowUnknown="false" ordinal="2" writeXmlBeforeImage="true">
<Name>success</Name>
<OrigName>success</OrigName>
<Type>3</Type>
<Mode>2</Mode>
</Parameter>

How can i change this definition to ensure that this parameter will be non-nullable? I tried adding nillable="false" which didn't work. I've also tried several other things but they just make the .wsm file unreadable.

Any advice is much appreciated.
 

mollyfud

Member
Have you tried checking the ProxyGen project and making sure all the settings in there for that variable are setup to not allow Unknowns for this Parameter? There are settings to say whether to use the individual parameters setting for that or to use a high levels default for it.
HTH
 

DCraig

New Member
Hi mollyfud,

Thanks for your response.

I'm not actually using the ProxyGen tool, i just had an example .wsm file that one of my colleagues had used in the past. I'm not even sure i can get access to ProxyGen.

Surely the ProxyGen tool would just add another flag somewhere in the .wsm file to indicate that the parameter is non-nullable?

Thanks
 

mollyfud

Member
Hmmm... Yeah, it might be that you need to note that its to use the parameters value at a higher level.
I have attached a 11.4 wsm file that has it set to use the parameters value for whether to allow unknown or not. It might help you work out other things to change.
 

Attachments

DCraig

New Member
Alright thanks for that. We have Openedge 10.2A02 which is old i know...But I'll have a look at that .wsm file line by line and see if i can see anything missing. Will post back here with results.
 
Top