Unable to start adminserver and brokers


New Member
Hello All,
As part of DR drill, Unix team recovered AIX server on other data center. After that, I tried to start DB's and services but facing an issue with admin servers. Progress versions 10.2b and 10.1c

I see this kind of lines recorded in admin log.
"root:380: System generated password has expired (9908)".

Can anyone help me, please?

Thanks in Advance..!


New Member
Have you tried a Knowledgebase search? This one looks relevant: Progress KB - Error 9908 9909 trying connect to AdminServer on UNIX.
Thanks for the response!

1. Progress versions - OE 10.1C04 and OE 10.2B03
2. OS - AIX 7.1
3. As part of DR tests, unix team copied entire system from current live system to different location and started the server. Now we need to start all progress DB's but I am facing issue while starting the admin server in both the OE 10.1C04 and OE 10.2B03 environments.

When I tried to start admin server, it takes too long to start but fails. Admserver logs recording the below lines repeatedly.

"root:380: System generated password has expired (9908)".

No changes done to progress related files, and also verified the links like this Progress KB - Error 9908 9909 trying connect to AdminServer on UNIX. but no luck still.

Any help much appreciated!
Manohar, are you logging in directly on the AIX server console using ROOT? Or are you using PUTTY, etc?

This might be your ROOT password problem somehow. I've not done AIX stuff for a while. moved to Red Hat.
Normally my RHL logging in as ROOT is not allowed, so I have to do "sudo ..." to start the DB and services. This way I don't need to authenticate as ROOT.

Also check your /etc/hosts file for any conflicts... Sometimes admins copy one server to another location, change the IP address, so it does not conflict with the other old server, etc. Maybe there is some sort of mismatch.

Checking the DNS entries is the obvious choice. In my place I don't see two different server aliases pointing to one IP address.