[Stackoverflow] [Progress OpenEdge ABL] perl script call from OpenEdge application causes error: unable to lookup symbol boot_DynaLoader

Not open for further replies.


As part of the AWS migration, we are hosting our application in the EC2 Instance (Amazon Linux 2, 64 Bit) with Perl 5.16.3 at the OS level. We have created a Perl script to be invoked as an OS shell command for sending application-specific emails. Amazon SES will be used to sent emails and the script was created with the guideline provided in the Amazon SES documentation. The script is to be used with the Perl version installed at the OS level and we have "shebang" pointing to the '/usr/bin/perl'.

We have tested the script by invoking the same from the Procedure editor and from application-specific "sudo" user and root as well. All these cases worked and we try to do the same from the application and we have the error "/usr/bin/perl: symbol lookup error: /usr/bin/perl: undefined symbol: boot_DynaLoader" . We have also tried invoking simple scripts to display sample messages from the application and we have the same error.

On analysis, we could see that the application uses OE 11.7.8 with Perl 5.6.1. We have also tried prioritizing the PATH to specifically use the "/usr/bin" (when OS level Perl is present) & "/usr/lib64/perl5" (where the required library files are present) while calling the script from the shell. (Set the PATH and export it just before the call)

We suspect that the error is due to some dependency of the App server call with the OE specific Perl binaries and we tried modifying the shebang to use the OE specific Perl in the DLC path and the "boot_DynaLoader" error is changed and we are not able to use any specific library files with this change. We also tried updating PATH environment variable in proadsv file and re-started all app/web/db/AdminServers. Still the path is reset to Old one.

We would like to know

  1. Why we are not able to invoke the Perl script specific to the one installed at the OS level?
  2. Can we have a patch of OE with Perl 5.16.3 or the latest one?
  3. Is it possible to update the Perl inside DLC without a patch and its impacts?

Continue reading...
Not open for further replies.