Question OEPDS Syntax Styling

Chad

New Member
Hi there,

When developing webspeed applications in the OEPDS Im finding the syntax styling to be incorrect. When I breakout of a line of webspeed code to add a reference to a database field the styling seems to render incorrectly (Please see attached image). 1953
It seems to read the period between the databaseName.databaseField as the EOL marker and subsequently throws out the rest of the styling. I have looked to see if there are options in the preferences to handle this but unfortunately cant see any. I understand I could just reference the field, however I need to reference table.field. Is there a way around this? Thanks for any help.

OEPDS 11.5
 

Attachments

Last edited:

andre42

Member
Actually for me it looks more like it got confused by the single and double quotes. Does it help to escape the single quotation mark after href= with the tilde sign ~ ?
Or you could try a newer version of OpenEdge, 11.7 is available for quite a while now.
On the other hand I have seen the OEPDS parser having trouble with some stuff occasionally, especially when using include files.
 
Top