Syteline progress version 8.3C17

#1
Has anyone ever gotten the where clause to work in a data administration extract from progress 8.3C17? No matter what I put in there, if i'm querying a Date parameter, text field, numeric field, I get the same error. this example just happens to use a date.
 

Attachments

#2
No, I've never been able to work around that issue either. I'm assuming its a bug in ver. 8.3C.
Anyways, you should be able to replicate the same data file extract with a few lines of Progress code.
Have you tried creating your own code to provide the output in the Procedure Editor?
 
#3
I'm not that comfortable with progress or Syteline to try that. I am more of a C#, .Net person. If you can point me to any additional documentation, I'd be willing to try.
 

Cringer

ProgressTalk.com Moderator
Staff member
#4
Isn't that screen expecting a Progress where clause?
Code:
WHERE inv-item.inv-date GE 07/01/18 AND inv-item.inv-date LE 07/21/18
 

Cringer

ProgressTalk.com Moderator
Staff member
#6
Try removing the WHERE. I can't test it myself. I would play around with a simple query until you get it working.
 
#7
It won't work here within the Data Admin tool in this specific version of Progress and Symix / Syteline. I've tried it many times before as well. Its a bug of some sort. There are solutions, although they may not be the solutions you want to undertake...
1. Run this query in the Procedure Editor. Works great!
2. Upgrade to Progress version 9 or higher. Bug disappears in the newer versions!
 

Cringer

ProgressTalk.com Moderator
Staff member
#8
Thanks darren. Upgrading is definitely an imperative The current version is 11.7, with 12 on the horizon.
 
Top