[Stackoverflow] [Progress OpenEdge ABL] Progress Developer Studio for OpenEdge issues syntax error but the same code will not get any syntax error whe

Not open for further replies.


PDSOE version 4.5.2, OE 11.7.1 - 64-bit - Win 10 64

I have an Webspeed (.w) opened in my PSDOE. If I simply right click over this code and choose Check Syntax in the context menu (Ctrl+Shift+C) it will return me an error from an include file used by this .w regarding the get-cookie():

Syntax Check: ** Unable to understand after -- "GET-COOKIE". (247)

In my .w, I have all the necessary Webspeed include files - including proto.i that will have the forward get-cookie function signature and all that.

So far so good, I could have thought of Propath and all that, but two things make things more complicated now:

  1. If I choose to compile the code instead of checking syntax, it will compile just fine - which tells me that all my include files and propath are correctly configured and all set, a .r is produced

  2. If from PDSOE, with my code still opened, I go in Eclipse \ OpenEdge \ Tool \ Procedure Editor , it will open a Progress Editor with the same code in place right, and from this procedure editor, if I simply right click and check syntax, it will return no errors at all.

I downloaded OE 12.3 and tried the same thing, got the same behavior. I checked all the propath and it was right (code compiles) I tried restarting the AVM, no difference I tried a shared AVM, no difference

I am running out of ideas specially after I got the same issue on 12.3.

Would you happen to have any other idea or could thing of anything else that could explain the check syntax behavior in PDSOE?


Continue reading...
Not open for further replies.