Answered Some programs returning "Unable to run Web object" on new server

Potish

Member
We have completed a migration from from an old server to a new server for our webspeed application. Most of the setup is done but we have some pages (no all) that keep returning the error "Unable to run Web object folder/program.r". I cannot determine why these pages are getting this error. They did compile and I do see that compile code on the correct folders. We have not made any code changes as part of this migration. Our new setup is as follows

Windows 2019 Server
IIS using cgiip.wsc
OpenEdge 11.3
 

Potish

Member
Thank you for the response. Your third suggestion helped me identify the problem. From the webSpeed log I found out the programs getting an error were trying to run r-code from a program that had not successfully compiled. I fixed this and issue was resolved.

We will be looking to upgrade to a Windows 2019 Server supported OE version in the near future.
 

dimitri.p

New Member
I'm curious to know:
Why go through all the "upgrading" trouble and excitement only to end up with Server 2019 in 2023 ?
 

Potish

Member
I'm curious to know:
Why go through all the "upgrading" trouble and excitement only to end up with Server 2019 in 2023 ?
In hindsight I should have upgraded to Server 2022 but I opted for server 2019 as I was not sure if I could fully configure our version of OE 11.3 on either version and decided to start with lower version. We are hoping to upgrade to OE 11.7 or OE 12 in the coming year and if we do we will also upgrade the OS.
 

Rob Fitzpatrick

ProgressTalk.com Sponsor
OE 11.7 will retire in March of 2025. If you are in the planning stages of an upgrade project, I would recommend 12.8.
 
Top