• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Question Smtp Mail Setup With Office 365

#1
I have setup an email send program using officer 365 mail and it is not working properly. hear i attached the error log.

11/10/17 17:36:13
************** ****** New Group ******* ************
Socket email started
Input Parameters
EmailFrom = kasun@abansfinance.lk
EmailReplyTo =
EmailTo = kasundha@gmail.com
EmailCC =
Attachments =
LocalFiles =
Subject = Early Settlement
Body = test
MIMEHeader =
LocalHostName = localhost
Delivery Receipt = no
Read Receipt = no
Importance = 1
DoAuth = yes
AuthType = base64
User = kasun@abansfinance.lk
Password = <Hidden>
11/10/17 17:36:13 opening socket
11/10/17 17:36:13 Socket Connection Established.
11/10/17 17:36:13 Number of lines: 2
str:220 SG2PR04CA0137.outlook.office365.com Microsoft ESMTP MAIL Service ready at Fri, 10 Nov 2017 12:06:50 +0000


11/10/17 17:36:13 Parse Line:1
Line:220 SG2PR04CA0137.outlook.office365.com Microsoft ESMTP MAIL Service ready at Fri, 10 Nov 2017 12:06:50 +0000
11/10/17 17:36:13 Begin read state 1
RESP:220 SG2PR04CA0137.outlook.office365.com Microsoft ESMTP MAIL Service ready at Fri, 10 Nov 2017 12:06:50 +0000


11/10/17 17:36:13 1 220 EHLO
11/10/17 17:36:13 newstate 2
CLIENT:EHLO kasun@abansfinance.lk


11/10/17 17:36:13 newstate - before 0 28 0
11/10/17 17:36:13 newstate - after 28 28 28
11/10/17 17:36:13 End read state 2
11/10/17 17:36:18 Number of lines: 2
str:501 5.5.4 Invalid domain name [SG2PR04CA0137.apcprd04.prod.outlook.com]


11/10/17 17:36:18 Parse Line:1
Line:501 5.5.4 Invalid domain name [SG2PR04CA0137.apcprd04.prod.outlook.com]
11/10/17 17:36:18 Begin read state 2
RESP:501 5.5.4 Invalid domain name [SG2PR04CA0137.apcprd04.prod.outlook.com]


11/10/17 17:36:18 2 501 AUTH LOGIN
11/10/17 17:36:18 End read state -1
11/10/17 17:36:18 501 5.5.4 Invalid domain name [SG2PR04CA0137.apcprd04.prod.outlook.com]


11/10/17 17:36:18 End SMTP Session
 

Cecil

17+ years progress programming and still learning.
#3
So, this is the same problem here. Smtp Mail Setup

Are you able to replicate this issue using a command line tool like mailsend?

There could be a DNS issue can you change DNS servers 8.8.8.8 for testing.

I can't ping SG2PR04CA0137.apcprd04.prod.outlook.com either so I'm not sure what is going on??

Strange thing to try is to change the password for the kasun@abansfinance.lk user.



REF:
mailsend https://github.com/muquit/mailsend