1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Question Oe 11.7 64 Bit

Discussion in 'Database Admin' started by gasomma, Nov 3, 2017.

  1. gasomma

    gasomma Member

    Hi to All,

    I'm going to install 11.7 64 bit workgroup and client networking on Windows Server.
    I will have problem for connect a PC 32 bit?

    Many thanks.
    A.
     
  2.  
  3. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    When an ABL client connects remotely (i.e. via TCP/IP) to a database, the client and server don't have to have the same architecture (32-bit or 64-bit). You won't have a problem.

    They only need to be the same when the client and server are on the same machine and the client connects via shared memory (i.e. without -S).
     
  4. gasomma

    gasomma Member

    Many thanks for reply. I will try.
     
  5. gasomma

    gasomma Member

    But I cannot install client networking 64 on Pc 32. Correct?
     
  6. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    If "PC 32" means you have a PC with a 32-bit operating system, you can't install 64-bit *anything*. You can only install 32-bit software on a 32-bit OS. You can install 32-bit or 64-bit software on 64-bit Windows.
     
  7. gasomma

    gasomma Member

    Yes this is right. Bit usually I install client-networking on any PC. On 64-bit server I have installed 11.7 64-bit and "as client" there are different PC: 32-bit and 64-bit.
    What's the right way for "anything" working properly?
    Many thaks.
    A.
     
  8. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    Any client application that runs on a machine other than the server connects via TCP. Therefore it can use either 32-bit or 64-bit, assuming your application is compatible with either one. Just ensure you start your database broker with the -S parameter (broker port or service name), and have those clients start with -H <server hostname> -S <broker port or service name>. You can use that same configuration on PCs with either 32-bit or 64-bit OpenEdge installed.
     
  9. gasomma

    gasomma Member

    Doesn't working. 64-bit using prowin.exe while 32-bit using prowin32.exe. Running 32-bit PC OE shows message error.
     
  10. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    Please provide specifics. I'm trying to help you but I don't want to guess what you're doing where and what it says on your screen.

    Let's start over. Tell me:
    • How many computers are involved, client and server, and which release(s) of OpenEdge are installed on each.
    • The host names of those computers.
    • The relevant client/server parameters used to start the database ABL broker.
    • The full command line used to start a client, including all parameters. If a parameter file (.pf) is used, show its contents.
    • The host name of the computer that client runs on.
    • The full text of the error message that resulted from running that command line.
    If there are n clients, provide the information for the last three bullet points n times.
     
  11. gasomma

    gasomma Member

    Hi Rob, many thanks for your interesting.

    I have 4 PC's (2 32-bit, 2 64,bit) and 1 server 64-bit
    Installed on the server OE 11.7 studio, workgroup and client networking
    No OE installation on the 32-bit PC client, 64-bit PC client I have installed client networking and working fine.
    /* .pf file*/
    -db c:\ob1\domo40 -ld domo98 -N TCP -S domo40 -H 10.0.0.200
    -db c:\ob1\domogui -ld dsggui -N TCP -S domogui -H 10.0.0.200
    -db c:\ob1\domopos -ld dsgpos -N TCP -S domopos -H 10.0.0.200
    -Bt 350
    -c 30
    -nb 200
    -s 48
    -yy 1950
    -d dmy
    -mmax 8192
    -inp 32000
    -tok 1600
    -T c:\ob1\temp
    -p domo98.p

    /* command line */
    \\10.0.0.200\OpenEdge\bin\prowin.exe -basekey "INI" -ininame c:\ob1\progress.ini -pf \\10.0.0.200\parfile.pf

    /* The relevant client/server parameters used to start the database ABL broker. */
    call c:\obs\openedge\bin\proserve.bat c:\ob1\domo40 -B 500 -L 400000 -n 30 -S domo40 -H hostname -N TCP
    call c:\obs\openedge\bin\proserve.bat c:\ob1\domogui -B 500 -L 400000 -n 30 -S domogui -H hostname -N TCP
    call c:\obs\openedge\bin\proserve.bat c:\ob1\domopos -B 500 -L 400000 -n 30 -S domopos -H hostname -N TCP

    Error message regarding compatibilty 32-bit 64-bit program.

    I hope is all.

    Many thanks
     
  12. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    So the database server is 10.0.0.200.

    I still don't know where this command line is running, other than that I can guess it isn't on the server, and it's running the 64-bit OpenEdge client that is installed on the server, connecting to three databases on that same server.

    Seriously, do I have to get down on my knees and beg for the actual text of the error message?

    While I'm waiting for the actual error message, I'll make another guess. If this means that you are attempting to run prowin.exe (the 64-bit client executable) on a 32-bit version of Windows, that won't work. 32-bit Windows can only run 32-bit code; it can't run 64-bit *anything*, OpenEdge or otherwise. Try replacing it with prowin32.exe when running on 32-bit Windows.
     
  13. gasomma

    gasomma Member

    Hi Rob,

    doesn't exist prowin32.exe in OE 11.7 env.
     
  14. gasomma

    gasomma Member

    Hi Rob,

    another problem on the same server and OE license running OE Explorer. Do you help me?
     

    Attached Files:

  15. Cecil

    Cecil 17+ years progress programming and still learning.


    Does this message happen in all browsers? It's just I noticed that it's IE, and well.......its IE.
     
  16. gasomma

    gasomma Member

    I reinstall it (IE). Now work fine. Thanks.
     
  17. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    It does when you have a 32-bit Client Networking license. If you want to run code on a 32-bit Windows OS, that's what you will need. If necessary, it can be installed side-by-side with 64-bit OE.
     
  18. gasomma

    gasomma Member

    Working properly. I have installed 32-bit OE 11.7 on the same machine that there is 64-bit 11.7. I think is the only way.
     

Share This Page