1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Launching Mpro - Error 748 No More Resources

Discussion in 'QAD's MFG/PRO' started by Jeff Winchell, Apr 14, 2017.

  1. Jeff Winchell

    Jeff Winchell Member

    Well, it seems that when I run mpro /mypath/mydb, mpro ignores that database and does not setup a connection to that database. So then I tried
    mpro /mypath/mydb -S myportnumber
    and I got the error message
    The server or the system has no more resources. Please contact Progress Technical Support (748)

    I googled that message and got a page suggesting all sorts of things to try
    Progress KB - Corrective Measures for Error 748
    which are all greek to me at this moment, but I am wondering if this is related to our QAD 2013 EE installation (the main database for QAD is the one I am trying to run mpro on). This is all on Linux which I only know enough to be dangerous on, so if there are some suggestions about config files or typical programs to run to check things out, please be a bit more specific than if you were talking to a Linux admin. :) Thanks.

    I assume that even if I launched mpro with no parameters that as soon as tried to connect to a database there, that I would still get this error.
     
    Last edited: Apr 14, 2017
  2.  
  3. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    That's not what mpro does, unless someone has replaced or edited it. It resides in $DLC/bin. Try "which mpro" to see if there's another one higher in your path. Or just try "_progres dbname", as that's more or less what mpro ultimately does (I'm leaving out a few details but it should work).

    When you connect to the database by "mpro dbname" you are establishing a self-service connection to the database. When you add "-S brokerport" you are changing the connection type from self-service (aka shared memory) to TCP. This means there must be a broker configured on that port to accept connections, it must handle ABL clients, it must have spawned or be able to spawn a server, and at least one of the running servers must have an available connection slot. There are some other parameters that can also prevent connections if either they are set improperly or you have hit a limit based on your configuration.

    Typically, a 748 means that no more clients can connect to the database. So that could mean the -n database startup parameter (maximum allowed connections) is too low or, more likely, a brokers-specific startup parameter related to clients/server is at a maximum, like -Ma (maximum clients per server).

    Given that you are running this client from the server, you don't need -S. What you should do is determine why a self-service connection isn't working for you.
     
  4. Jeff Winchell

    Jeff Winchell Member

    Actually I went on a wild goose chase though I learned something from it (including all your comments above). This proved to be the solution to my exact problem:
    How To Use Mpro
     
  5. Rob Fitzpatrick

    Rob Fitzpatrick ProgressTalk.com Sponsor

    Good, glad you figured it out.
     

Share This Page